summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--app-admin/password-store/Manifest2
-rw-r--r--app-admin/password-store/metadata.xml19
-rw-r--r--app-admin/password-store/password-store-9999.ebuild31
-rw-r--r--dev-python/py-bcrypt/Manifest2
-rw-r--r--dev-python/py-bcrypt/py-bcrypt-0.2.ebuild25
-rw-r--r--net-misc/fatrat/Manifest2
-rw-r--r--net-misc/fatrat/fatrat-1.2.0_beta2.ebuild51
-rw-r--r--net-misc/tucan/Manifest2
-rw-r--r--net-misc/tucan/tucan-0.3.10.ebuild43
9 files changed, 177 insertions, 0 deletions
diff --git a/app-admin/password-store/Manifest b/app-admin/password-store/Manifest
new file mode 100644
index 0000000..2456338
--- /dev/null
+++ b/app-admin/password-store/Manifest
@@ -0,0 +1,2 @@
+EBUILD password-store-9999.ebuild 640 SHA256 bd4a315fe897cf9c1a0ccd4965f4b2aa583831990b773a41a103918b49d9524f SHA512 ad3da4a3b99834724d3a62175f6c964b78cb930d53216d853792685b266549ef7d3b4cfbd2a1ff709e8f62e24f7814452de7c3796fa45e89c9608e17b61f0b27 WHIRLPOOL a11f8d46f22a7c1babc9baf00645d3a298bb1559041533fb5f926bda1c7239f3b3f830c73522510035f3a4391d9730a6752cf1e454e0b26e246ef1b93081dfea
+MISC metadata.xml 596 SHA256 ee9eea8b8f3cd152f6cb6731006b2b517dd8b3102d79a7ea0719d9095fe442bf SHA512 70873e33ad11c65d8a726a8cba3497cca47514ad26c7cf2a900a7c0ba4aea520b430fec8f26053a76680cf0fe6eaed9e4bbc3eba16df3ce07479f944abf4f2f0 WHIRLPOOL fd395a953b33e306f55cc983ae95b8a94a15ea0da6781ce52b403b354c168aa0968b89d16468b51db0f6ee1ce236e702c187a5bffb11320be0d8119d3fbce07a
diff --git a/app-admin/password-store/metadata.xml b/app-admin/password-store/metadata.xml
new file mode 100644
index 0000000..b5201a2
--- /dev/null
+++ b/app-admin/password-store/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>security</herd>
+ <maintainer>
+ <email>Jason@zx2c4.com</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <longdescription>
+ Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git.
+ </longdescription>
+ <flag name='X'>
+ Use <pkg>x11-misc/xclip</pkg> to copy passwords to the clipboard.
+ </flag>
+ <flag name='git'>
+ Use <pkg>dev-vcs/git</pkg> for password revisions.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-admin/password-store/password-store-9999.ebuild b/app-admin/password-store/password-store-9999.ebuild
new file mode 100644
index 0000000..0f8e32c
--- /dev/null
+++ b/app-admin/password-store/password-store-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2012 Jason A. Donenfeld <Jason@zx2c4.com>
+
+EAPI=4
+
+inherit bash-completion-r1 git-2
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely using gpg, pwgen, and git."
+HOMEPAGE="http://www.zx2c4.com"
+SRC_URI=""
+EGIT_REPO_URI="http://git.zx2c4.com/password-store"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +git"
+
+RDEPEND="app-crypt/gnupg
+ app-admin/pwgen
+ git? ( dev-vcs/git )
+ X? ( x11-misc/xclip )
+"
+
+src_compile() {
+ mv src/password-store.sh src/pass
+}
+
+src_install() {
+ dobin src/pass
+ doman man/pass.1
+ dodoc README
+ newbashcomp bash-completion/pass-bash-completion.sh ${PN}
+}
diff --git a/dev-python/py-bcrypt/Manifest b/dev-python/py-bcrypt/Manifest
new file mode 100644
index 0000000..3575912
--- /dev/null
+++ b/dev-python/py-bcrypt/Manifest
@@ -0,0 +1,2 @@
+DIST py-bcrypt-0.2.tar.gz 16804 SHA256 86a798053e41620e64c41b9d6cfd820ac4a564ed4030a5fb177b9daef6bbacba SHA512 d01f263ebb309b4018e457714f8a2cfad6b3a4c33c8b151e2c66de3a658a8495e50704ce10122f0cb551f7669fa9a8f9fdc8d2c5af22e39352c22feb45eaf777 WHIRLPOOL 4f4735505c1e744c516159f0d4a04231e1d21a1fd5e37bc6e85a59c76f92155f1558ab69511c9427346308934d946662ebb653c668d189dff45e6d043529ac98
+EBUILD py-bcrypt-0.2.ebuild 614 SHA256 1e239164adb96205843c182f3ad692a8fbd5bbf68e21ea0e7bcbf46490f9cef1 SHA512 e14ff0abf19229f07c6906f95aac6f513ee4470eff82c8d2e75e74bd500c73dbf57ac624d3240c3c257c6c58335c9bc7d8f17a312765ef477ca96a7b66ea3d41 WHIRLPOOL 8a72893b2099329f8fed63be16324c0780ef96ea1cb90eee418ee3b6af192d513986caeedb8049f3ea7219e6d585237d3f98b44ae50b65a8a468b3e2623b2ad2
diff --git a/dev-python/py-bcrypt/py-bcrypt-0.2.ebuild b/dev-python/py-bcrypt/py-bcrypt-0.2.ebuild
new file mode 100644
index 0000000..03219b2
--- /dev/null
+++ b/dev-python/py-bcrypt/py-bcrypt-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2011-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="py-bcrypt is an implementation of the OpenBSD Blowfish password hashing algorithm"
+HOMEPAGE="http://www.mindrot.org/projects/py-bcrypt
+https://code.google.com/p/py-bcrypt/"
+SRC_URI="http://www.mindrot.org/files/${PN}/${P}.tar.gz
+http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="ChangeLog LICENSE README TODO"
diff --git a/net-misc/fatrat/Manifest b/net-misc/fatrat/Manifest
new file mode 100644
index 0000000..11487ca
--- /dev/null
+++ b/net-misc/fatrat/Manifest
@@ -0,0 +1,2 @@
+DIST fatrat-1.2.0_beta2.tar.xz 3677188 SHA256 b9e1116e5754a2cfff952908145eea6f27454cd8a2260422a54be59e43d2d5e5 SHA512 f8ca441eb7f2264d6c3b6968bcbfc01dcc495340d7b34432a9430065ec7fb4e8f5ce68cde77de42d61577fe3f46014d9ce041ca513e17da8afab2c0888352751 WHIRLPOOL f5c774872c7d9b4f09dd13a04cd0d21a706195eecec103ab883029013228d473f8b82975cc61afcd93001be19ab3350e22288523bc7cac3c043dd2e3e13e0d4f
+EBUILD fatrat-1.2.0_beta2.ebuild 1363 SHA256 982b5e4e4bd795cd4d698df5003be6335af7bb2372e74841042fdd4c602e7eb6 SHA512 e39c34e6d85f283de994d490479ab396ed9ce70e27a0606f87e8944826032c3074343e6a66b54f2d23f67620e3799cedb647ff102ba1c2a608f559e84c1a2ea1 WHIRLPOOL 3e64386bc0d60701b88a45d7312f7f3db0913440583b1ea89e37c6cc089ee02355b1a873674aba795d02e6049649029711071b4d00f10ff65b4ee83684a974aa
diff --git a/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
new file mode 100644
index 0000000..7e4fb02
--- /dev/null
+++ b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4-based download/upload manager"
+HOMEPAGE="http://fatrat.dolezel.info/"
+SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bittorrent +curl doc jabber nls webinterface"
+
+RDEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ bittorrent? ( >=net-libs/rb_libtorrent-0.14.5
+ >=dev-cpp/asio-1.1.0
+ x11-libs/qt-webkit:4 )
+ curl? ( >=net-misc/curl-7.18.2 )
+ doc? ( x11-libs/qt-assistant:4 )
+ jabber? ( net-libs/gloox )
+ webinterface? ( x11-libs/qt-script:4 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_with bittorrent) \
+ $(cmake-utils_use_with curl) \
+ $(cmake-utils_use_with doc DOCUMENTATION) \
+ $(cmake-utils_use_with jabber) \
+ $(cmake-utils_use_with nls) \
+ $(cmake-utils_use_with webinterface)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ # this is a completely optional and NOT automagic dep
+ if ! has_version dev-libs/geoip; then
+ elog "If you want the GeoIP support, then emerge dev-libs/geoip."
+ fi
+}
diff --git a/net-misc/tucan/Manifest b/net-misc/tucan/Manifest
new file mode 100644
index 0000000..c1c3f67
--- /dev/null
+++ b/net-misc/tucan/Manifest
@@ -0,0 +1,2 @@
+DIST tucan-0.3.10.tar.gz 545190 SHA256 41c4e68de970eb4388b41fa75b7c38142b989483318490abf8af377303c99e5c SHA512 937370d902a8a7a62e714a453e418aa95f699d739d94615ad8ba3d7181be0534bbf4f591d20054ddb64496fd94f378448d514e1179740485dc921241cb6b6cf4 WHIRLPOOL 72dc96a02ab377ef6840d56ca6e2cc664eb32bc3d83b81711dca1a5e1f418f5e4b50feb721525a52be9acf6f5aef0d63a08b7a820430037cdbbfab7490e095c8
+EBUILD tucan-0.3.10.ebuild 1055 SHA256 92b9cc620304bafe59536c0bbd7781d065527dc037a99067af903ac85f3bc97e SHA512 616a4c257dcf3aed0c17b101e2566797c51df21ce1773752dae000a2217cee90acc819addd5a36ddd0da4c5f8935dfc012aca256b0a7c54ce2cb08f0592d7001 WHIRLPOOL a99b2720b3e36f90bfb40622043c6eb9c2b65e1e951e55a0141515e0e3bf3f0d99ff64227eca3e19c36bad6ac971531791e4ac2a7f0c0720aeffcc7473d2264c
diff --git a/net-misc/tucan/tucan-0.3.10.ebuild b/net-misc/tucan/tucan-0.3.10.ebuild
new file mode 100644
index 0000000..535595e
--- /dev/null
+++ b/net-misc/tucan/tucan-0.3.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Manages automatic downloads and uploads from one-click hosting sites like RapidShare"
+HOMEPAGE="http://tucaneando.com/"
+SRC_URI="http://forja.rediris.es/frs/download.php/2051/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="dev-lang/python
+ gtk? ( dev-python/pygtk
+ gnome-base/librsvg )
+ app-text/tesseract
+ dev-python/imaging"
+
+src_compile() { :; }
+
+src_install() {
+ emake DESTDIR="${D}"/usr install || die "emake install failed"
+ dodoc CHANGELOG README || die "dodoc failed"
+ if use gtk ; then
+ doicon media/scalable/tucan.svg || die "doicon failed"
+ make_desktop_entry tucan Tucan
+ fi
+}
+
+pkg_postinst() {
+ if ! use gtk ; then
+ ewarn "Please be aware that Tucan curses interface is still under"
+ ewarn "development."
+ ewarn
+ ewarn "You should use 'tucan --cli' for curses interface or"
+ ewarn "simply use 'tucan --daemon' to use it daemonized."
+ fi
+}