summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--app-doc/x86-manpages/x86-manpages-9999.ebuild25
-rw-r--r--app-text/ripgrep/Manifest1
-rw-r--r--app-text/ripgrep/ripgrep-0.2.6.ebuild24
3 files changed, 25 insertions, 25 deletions
diff --git a/app-doc/x86-manpages/x86-manpages-9999.ebuild b/app-doc/x86-manpages/x86-manpages-9999.ebuild
new file mode 100644
index 0000000..e4b2a18
--- /dev/null
+++ b/app-doc/x86-manpages/x86-manpages-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Man pages for x86 instructions"
+HOMEPAGE="https://github.com/ttmo-O/x86-manpages"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/ttmo-O/x86-manpages"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() { :; }
+src_install() {
+ doman manpages/*
+}
diff --git a/app-text/ripgrep/Manifest b/app-text/ripgrep/Manifest
deleted file mode 100644
index 0eec546..0000000
--- a/app-text/ripgrep/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ripgrep-0.2.6-x86_64-unknown-linux-musl.tar.gz 3561487 SHA256 aaf36763ddf177b383ea53d7b926590565ddbb3e4cd8d7ded49ec9a64b808916 SHA512 10bf9e3ce052d3dba8e7d6cab56bd8dd6d40f00b65db92f50d984a7de65a39854463f1b88ee28acd06c2058f618f0b5430f4b24005766c88665152c108f990dc WHIRLPOOL dc6307edce0875d605d6ec586dcb9f33413d06f5d7c6615269d148ef5a8d0a164d1e639e06c24373d72bac17bc1e7764734bd44c3436ee4b69f360e27ca21b66
diff --git a/app-text/ripgrep/ripgrep-0.2.6.ebuild b/app-text/ripgrep/ripgrep-0.2.6.ebuild
deleted file mode 100644
index 02684cf..0000000
--- a/app-text/ripgrep/ripgrep-0.2.6.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-DESCRIPTION="ag/grep replacement"
-HOMEPAGE="https://github.com/BurntSushi/ripgrep"
-SRC_URI="https://github.com/BurntSushi/ripgrep/releases/download/${PV}/${P}-x86_64-unknown-linux-musl.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}-x86_64-unknown-linux-musl"
-
-src_install() {
- dobin rg
- doman rg.1
-}