summaryrefslogtreecommitdiffstats
path: root/dev-util/arcanist/arcanist-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/arcanist/arcanist-9999.ebuild')
-rw-r--r--dev-util/arcanist/arcanist-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/arcanist/arcanist-9999.ebuild b/dev-util/arcanist/arcanist-9999.ebuild
new file mode 100644
index 0000000..ec3198c
--- /dev/null
+++ b/dev-util/arcanist/arcanist-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Command line interface for Phabricator"
+HOMEPAGE="https://github.com/phacility/arcanist"
+EGIT_REPO_URI=( "https://github.com/phacility/${PN}.git" )
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php
+ dev-libs/libphutil
+"
+
+src_install() {
+ dodir /opt/${PN}
+ cp -a "${S}"/* "${D}/opt/${PN}"
+ dosym /opt/${PN}/bin/arc /usr/bin/arc
+}