summaryrefslogtreecommitdiffstats
path: root/net-fs/ncpfs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/ncpfs')
-rw-r--r--net-fs/ncpfs/Manifest3
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6.ebuild56
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6.ebuild.diff21
3 files changed, 0 insertions, 80 deletions
diff --git a/net-fs/ncpfs/Manifest b/net-fs/ncpfs/Manifest
deleted file mode 100644
index e557a45..0000000
--- a/net-fs/ncpfs/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ncpfs-2.2.6.tar.gz 2100545 RMD160 a02fcef8fff0f65f7ddbdd83b092a484a0372186 SHA1 00d83771ef14f2aeb039430a44201e33cd80a894 SHA256 2837046046bcdb46d77a80c1d17dbfd15e878700e879edab4cda9f080e0337f9
-EBUILD ncpfs-2.2.6.ebuild 1433 RMD160 8f55afe98c563f83e73846257b690292235fcc0c SHA1 15fd75a7296b10e5154e15b021c924a93d683e40 SHA256 3bc788c39d2b25d0e998d95cc6063fb5bf4aa01708f8a511abe51161ab42c0fb
-MISC ncpfs-2.2.6.ebuild.diff 582 RMD160 48f353c1a410e09fef6f8e9824b1e3af5967ca4d SHA1 87011f3753343bc9cab7576a049ffd8977e90123 SHA256 85b67c6f81803181410d338a30e5a90d03eca725bb88de74eeefafe16aa31a84
diff --git a/net-fs/ncpfs/ncpfs-2.2.6.ebuild b/net-fs/ncpfs/ncpfs-2.2.6.ebuild
deleted file mode 100644
index 16688eb..0000000
--- a/net-fs/ncpfs/ncpfs-2.2.6.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6.ebuild,v 1.5 2008/05/14 22:16:53 flameeyes Exp $
-
-inherit eutils confutils
-
-IUSE="nls pam php install-dev"
-
-DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
-SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
-HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~amd64 ~ppc ppc64"
-
-DEPEND="nls? ( sys-devel/gettext )
- pam? ( virtual/pam )
- php? ( || ( virtual/php virtual/httpd-php ) )"
-
-src_unpack() {
- unpack ${A}
-
- # add patch for PHP extension sandbox violation
- cd ${S} || die "Unable to cd to ${S}"
- epatch "${FILESDIR}"/${PN}-2.2.5-php.patch || die "Unable to apply PHP patch"
- epatch "${FILESDIR}"/${P}-gcc4.patch
- epatch "${FILESDIR}"/${P}-missing-includes.patch
-}
-
-src_compile() {
-
- local myconf
-
- myconf=
- enable_extension_enable "nls" "nls" 0
- enable_extension_enable "pam" "pam" 0
- enable_extension_enable "php" "php" 0
-
- econf ${myconf} || die "econf failed"
- emake || die
-}
-
-src_install () {
- # directory ${D}/lib/security needs to be created or the install fails
- dodir /lib/security
- dodir /usr/sbin
- dodir /sbin
- make DESTDIR=${D} install || die
-
- if use install-dev; then
- make DESTDIR=${D} install-dev || die
- fi
-
- dodoc FAQ README
-}
diff --git a/net-fs/ncpfs/ncpfs-2.2.6.ebuild.diff b/net-fs/ncpfs/ncpfs-2.2.6.ebuild.diff
deleted file mode 100644
index 96349ee..0000000
--- a/net-fs/ncpfs/ncpfs-2.2.6.ebuild.diff
+++ /dev/null
@@ -1,21 +0,0 @@
---- /usr/portage/net-fs/ncpfs/ncpfs-2.2.6.ebuild 2008-05-14 17:36:37.000000000 -0500
-+++ ncpfs-2.2.6.ebuild 2009-03-27 11:18:17.591620794 -0500
-@@ -4,7 +4,7 @@
-
- inherit eutils confutils
-
--IUSE="nls pam php"
-+IUSE="nls pam php install-dev"
-
- DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
- SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
-@@ -48,5 +48,9 @@
- dodir /sbin
- make DESTDIR=${D} install || die
-
-+ if use install-dev; then
-+ make DESTDIR=${D} install-dev || die
-+ fi
-+
- dodoc FAQ README
- }