summaryrefslogtreecommitdiffstats
path: root/net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild')
-rw-r--r--net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild b/net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild
new file mode 100644
index 0000000..2ca1ea7
--- /dev/null
+++ b/net-p2p/soulseek-qt/soulseek-qt-20130212.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Official binary Qt SoulSeek client."
+HOMEPAGE="http://www.soulseekqt.net/"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BINARY_NAME="SoulseekQt-${PV:0:4}-$((${PV:4:2}))-$((${PV:6:2}))"
+BASE_URI="http://www.soulseekqt.net/SoulseekQT/Linux/${BINARY_NAME}"
+IUSE=""
+SRC_URI="
+ x86? ( ${BASE_URI}.tgz )
+ amd64? ( ${BASE_URI}-64bit.tgz )
+ "
+DEPEND=""
+RDEPEND="
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ "
+RESTRICT="mirror"
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /usr/bin
+ use amd64 && BINARY_NAME="${BINARY_NAME}-64bit"
+ newexe "${BINARY_NAME}" "${PN}"
+}