aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/app/build.gradle
diff options
context:
space:
mode:
authorHarsh Shandilya <me@msfjarvis.dev>2020-03-09 19:00:14 +0530
committerHarsh Shandilya <me@msfjarvis.dev>2020-03-09 19:24:26 +0530
commitadc613d8011af7c508050badb1272e8326554c39 (patch)
tree4eadedc0767e1f4f482b7c22ec905329acab62a6 /app/build.gradle
parentToolsInstaller: restrict to only main app usage (diff)
downloadwireguard-android-adc613d8011af7c508050badb1272e8326554c39.tar.xz
wireguard-android-adc613d8011af7c508050badb1272e8326554c39.zip
Migrate tunnel related classes to tunnel/ Gradle module
Signed-off-by: Harsh Shandilya <me@msfjarvis.dev>
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle34
1 files changed, 2 insertions, 32 deletions
diff --git a/app/build.gradle b/app/build.gradle
index a32d14f0..a21c2027 100644
--- a/app/build.gradle
+++ b/app/build.gradle
@@ -65,51 +65,21 @@ android {
}
}
}
- externalNativeBuild {
- cmake {
- path 'tools/CMakeLists.txt'
- }
- }
-}
-
-ext {
- annotationsVersion = '1.1.0'
- appcompatVersion = '1.1.0'
- cardviewVersion = '1.0.0'
- coreKtxVersion = '1.2.0'
- constraintLayoutVersion = '1.1.3'
- coordinatorLayoutVersion = '1.1.0'
- databindingVersion = '3.6.0'
- fragmentVersion = '1.2.2'
- materialComponentsVersion = '1.1.0'
- jsr305Version = '3.0.2'
- kotlinVersion = '1.3.70'
- preferenceVersion = '1.1.0'
- streamsupportVersion = '1.7.1'
- threetenabpVersion = '1.2.2'
- // ZXING switched minSdk to 24 so we cannot upgrade to 4.0.2 without following suit.
- // If you choose to upgrade to minSDK 24 then you should also disable Jetifier from
- // gradle.properties.
- zxingEmbeddedVersion = '3.6.0'
- eddsaVersion = '0.3.0'
}
dependencies {
+ implementation project(":tunnel")
implementation "androidx.annotation:annotation:$annotationsVersion"
implementation "androidx.appcompat:appcompat:$appcompatVersion"
implementation "androidx.cardview:cardview:$cardviewVersion"
implementation "androidx.constraintlayout:constraintlayout:$constraintLayoutVersion"
implementation "androidx.coordinatorlayout:coordinatorlayout:$coordinatorLayoutVersion"
implementation "androidx.core:core-ktx:$coreKtxVersion"
- implementation "androidx.databinding:databinding-runtime:$databindingVersion"
+ implementation "androidx.databinding:databinding-runtime:$agpVersion"
implementation "androidx.fragment:fragment:$fragmentVersion"
implementation "androidx.preference:preference:$preferenceVersion"
implementation "com.google.android.material:material:$materialComponentsVersion"
- implementation "com.google.code.findbugs:jsr305:$jsr305Version"
- implementation "com.jakewharton.threetenabp:threetenabp:$threetenabpVersion"
implementation "com.journeyapps:zxing-android-embedded:$zxingEmbeddedVersion"
- implementation "net.sourceforge.streamsupport:android-retrofuture:$streamsupportVersion"
- implementation "net.sourceforge.streamsupport:android-retrostreams:$streamsupportVersion"
implementation "net.i2p.crypto:eddsa:$eddsaVersion"
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk8:$kotlinVersion"
}