aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/app/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2017-12-20 05:02:51 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2017-12-20 05:02:51 +0100
commit8937cf82fb348117eda45c0930e2d655bc89cd06 (patch)
treef20d8248c4a992434963efca4fba39e21812fc87 /app/tools/CMakeLists.txt
parenttools: force ld.gold (diff)
downloadwireguard-android-8937cf82fb348117eda45c0930e2d655bc89cd06.tar.xz
wireguard-android-8937cf82fb348117eda45c0930e2d655bc89cd06.zip
tools: add wg-quick directly
We also use all search paths for tool, since many want this to be CLI too. Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Diffstat (limited to 'app/tools/CMakeLists.txt')
-rw-r--r--app/tools/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/app/tools/CMakeLists.txt b/app/tools/CMakeLists.txt
index c0647a70..22ddbcc1 100644
--- a/app/tools/CMakeLists.txt
+++ b/app/tools/CMakeLists.txt
@@ -4,8 +4,8 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}")
# Work around https://github.com/android-ndk/ndk/issues/602
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=gold")
-add_executable(libwg-quick.so wireguard-android-integration/wg-quick.c)
-target_compile_options(libwg-quick.so PUBLIC -O3 -std=gnu11 -Wall -pedantic -Wno-missing-field-initializers -DWG_CONFIG_SEARCH_PATHS=\"\\\"/data/data/com.wireguard.android/files\\\"\")
+add_executable(libwg-quick.so wg-quick.c)
+target_compile_options(libwg-quick.so PUBLIC -O3 -std=gnu11 -Wall -pedantic -Wno-missing-field-initializers)
file(GLOB WG_SOURCES wireguard/src/tools/*.c libmnl/src/*.c)
add_executable(libwg.so ${WG_SOURCES})