aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
authorHarsh Shandilya <me@msfjarvis.dev>2020-03-14 10:32:12 +0530
committerHarsh Shandilya <me@msfjarvis.dev>2020-03-14 10:32:12 +0530
commit093139bc912018114f286edb269f1f8bc137c790 (patch)
tree57c78d16b97b625c9cfc35385062e7e5e5a37e02 /tunnel/build.gradle
parenttunnel: Remove MISSING_VALUE from BadConfigException reasons (diff)
downloadwireguard-android-093139bc912018114f286edb269f1f8bc137c790.tar.xz
wireguard-android-093139bc912018114f286edb269f1f8bc137c790.zip
tunnel: Add an initial set of unit tests
Includes a control set of broken configuration files that we attempt to parse and verify that the parser fails in a predictable and consistent manner. Signed-off-by: Harsh Shandilya <me@msfjarvis.dev>
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle6
1 files changed, 6 insertions, 0 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
index 6a2e1c0e..f306292c 100644
--- a/tunnel/build.gradle
+++ b/tunnel/build.gradle
@@ -21,6 +21,11 @@ android {
path 'tools/CMakeLists.txt'
}
}
+ testOptions.unitTests.all {
+ testLogging {
+ events 'passed', 'skipped', 'failed', 'standardOut', 'standardError'
+ }
+ }
}
dependencies {
@@ -30,6 +35,7 @@ dependencies {
implementation "com.google.code.findbugs:jsr305:$jsr305Version"
implementation "com.jakewharton.threetenabp:threetenabp:$threetenabpVersion"
implementation "net.i2p.crypto:eddsa:$eddsaVersion"
+ testImplementation "junit:junit:$junitVersion"
}
apply from: "publish.gradle"