aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
authorHarsh Shandilya <me@msfjarvis.dev>2020-04-08 17:04:08 +0530
committerHarsh Shandilya <me@msfjarvis.dev>2020-04-08 17:05:31 +0530
commit3fa8e09545c2ce2a87811476e7564313468eb7ed (patch)
tree8220f990ac291854a8ebe9f80fa224d30d128ce0 /tunnel/build.gradle
parentversion: bump (diff)
downloadwireguard-android-3fa8e09545c2ce2a87811476e7564313468eb7ed.tar.xz
wireguard-android-3fa8e09545c2ce2a87811476e7564313468eb7ed.zip
tunnel: disable BuildConfig generation
We don't (and shouldn't) use BuildConfig values, but the class was polluting our public API regardless which is undesirable. Signed-off-by: Harsh Shandilya <me@msfjarvis.dev>
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle3
1 files changed, 3 insertions, 0 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
index a2cc73e0..fa9a3f5f 100644
--- a/tunnel/build.gradle
+++ b/tunnel/build.gradle
@@ -21,6 +21,9 @@ android {
path 'tools/CMakeLists.txt'
}
}
+ libraryVariants.all {
+ it.generateBuildConfigProvider.configure { enabled = false }
+ }
testOptions.unitTests.all {
testLogging {
events 'passed', 'skipped', 'failed', 'standardOut', 'standardError'