aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle59
1 files changed, 0 insertions, 59 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
deleted file mode 100644
index ff1aad19..00000000
--- a/tunnel/build.gradle
+++ /dev/null
@@ -1,59 +0,0 @@
-plugins {
- id 'com.android.library'
-}
-
-version wireguardVersionName
-group groupName
-
-android {
- compileSdkVersion 31
- compileOptions {
- sourceCompatibility JavaVersion.VERSION_1_8
- targetCompatibility JavaVersion.VERSION_1_8
- }
- defaultConfig {
- minSdkVersion 21
- targetSdkVersion 31
- versionCode wireguardVersionCode
- versionName wireguardVersionName
- }
- externalNativeBuild {
- cmake {
- path 'tools/CMakeLists.txt'
- }
- }
- testOptions.unitTests.all {
- testLogging {
- events 'passed', 'skipped', 'failed', 'standardOut', 'standardError'
- }
- }
- buildTypes {
- release {
- externalNativeBuild {
- cmake {
- arguments "-DANDROID_PACKAGE_NAME=${groupName}", "-DGRADLE_USER_HOME=${project.gradle.gradleUserHomeDir}"
- }
- }
- }
- debug {
- externalNativeBuild {
- cmake {
- arguments "-DANDROID_PACKAGE_NAME=${groupName}.debug", "-DGRADLE_USER_HOME=${project.gradle.gradleUserHomeDir}"
- }
- }
- }
- }
- lintOptions {
- disable('LongLogTag')
- disable('NewApi') // Desugaring!
- }
-}
-
-dependencies {
- implementation "androidx.annotation:annotation:$annotationsVersion"
- implementation "androidx.collection:collection:$collectionVersion"
- compileOnly "com.google.code.findbugs:jsr305:$jsr305Version"
- testImplementation "junit:junit:$junitVersion"
-}
-
-apply from: "publish.gradle"