aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle30
1 files changed, 30 insertions, 0 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
new file mode 100644
index 00000000..65ac6ceb
--- /dev/null
+++ b/tunnel/build.gradle
@@ -0,0 +1,30 @@
+apply plugin: 'com.android.library'
+
+android {
+ buildToolsVersion '29.0.3'
+ compileSdkVersion 29
+ compileOptions {
+ sourceCompatibility JavaVersion.VERSION_1_8
+ targetCompatibility JavaVersion.VERSION_1_8
+ }
+ defaultConfig {
+ minSdkVersion 21
+ targetSdkVersion 29
+ versionCode 1
+ versionName '1.0'
+ }
+ externalNativeBuild {
+ cmake {
+ path 'tools/CMakeLists.txt'
+ }
+ }
+}
+
+dependencies {
+ api "net.sourceforge.streamsupport:android-retrofuture:$streamsupportVersion"
+ api "net.sourceforge.streamsupport:android-retrostreams:$streamsupportVersion"
+ api "com.google.code.findbugs:jsr305:$jsr305Version"
+ implementation "androidx.annotation:annotation:$annotationsVersion"
+ implementation "androidx.collection:collection:$collectionVersion"
+ implementation "com.jakewharton.threetenabp:threetenabp:$threetenabpVersion"
+}