aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tools/usb/usbip/libsrc/Makefile.am
diff options
context:
space:
mode:
authorKrzysztof Opasiak <k.opasiak@samsung.com>2016-03-08 21:49:04 +0100
committerGreg Kroah-Hartman <gregkh@linuxfoundation.org>2016-04-26 15:19:50 -0700
commit3391ba0e2792411dc3372b76a4662971d6eaa405 (patch)
treefbdcc3eaa65fbd29882b06f0300fef4afc91fb71 /tools/usb/usbip/libsrc/Makefile.am
parentusbip: vudc: Add SysFS infrastructure for VUDC (diff)
downloadwireguard-linux-3391ba0e2792411dc3372b76a4662971d6eaa405.tar.xz
wireguard-linux-3391ba0e2792411dc3372b76a4662971d6eaa405.zip
usbip: tools: Extract generic code to be shared with vudc backend
Extract the code from current stub driver backend and a common interface for both stub driver and vudc. This allows to share most of the usbipd code for both of them. Based on code created in cooperation with Open Operating Systems Student Society at University of Warsaw (O2S3@UW) consisting of: Igor Kotrasinski <ikotrasinsk@gmail.com> Karol Kosik <karo9@interia.eu> Ewelina Kosmider <3w3lfin@gmail.com> Dawid Lazarczyk <lazarczyk.dawid@gmail.com> Piotr Szulc <ps347277@students.mimuw.edu.pl> Tutor and project owner: Krzysztof Opasiak <k.opasiak@samsung.com> Signed-off-by: Krzysztof Opasiak <k.opasiak@samsung.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Diffstat (limited to 'tools/usb/usbip/libsrc/Makefile.am')
-rw-r--r--tools/usb/usbip/libsrc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/usb/usbip/libsrc/Makefile.am b/tools/usb/usbip/libsrc/Makefile.am
index 7c8f8a4d54e4..eb62f99cc0ee 100644
--- a/tools/usb/usbip/libsrc/Makefile.am
+++ b/tools/usb/usbip/libsrc/Makefile.am
@@ -4,5 +4,6 @@ libusbip_la_LDFLAGS = -version-info @LIBUSBIP_VERSION@
lib_LTLIBRARIES := libusbip.la
libusbip_la_SOURCES := names.c names.h usbip_host_driver.c usbip_host_driver.h \
- usbip_common.c usbip_common.h vhci_driver.c vhci_driver.h \
+ usbip_common.c usbip_common.h usbip_host_common.h \
+ usbip_host_common.c vhci_driver.c vhci_driver.h \
sysfs_utils.c sysfs_utils.h