aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/tools/usb/usbip/libsrc/Makefile.am
diff options
context:
space:
mode:
authorValentina Manea <valentina.manea.m@gmail.com>2014-08-20 07:30:59 +0300
committerGreg Kroah-Hartman <gregkh@linuxfoundation.org>2014-08-25 10:38:56 -0700
commit588b48caf65c4a92af567948ec0025065e749ddf (patch)
tree6cf9771e522864db1685ffd7cabd31439fe93305 /tools/usb/usbip/libsrc/Makefile.am
parentMerge tag 'fixes-for-v3.17-rc2' of git://git.kernel.org/pub/scm/linux/kernel/git/balbi/usb into work-linus (diff)
downloadwireguard-linux-588b48caf65c4a92af567948ec0025065e749ddf.tar.xz
wireguard-linux-588b48caf65c4a92af567948ec0025065e749ddf.zip
usbip: move usbip userspace code out of staging
At this point, USB/IP userspace code is fully functional and can be moved out of staging. Signed-off-by: Valentina Manea <valentina.manea.m@gmail.com> Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Diffstat (limited to 'tools/usb/usbip/libsrc/Makefile.am')
-rw-r--r--tools/usb/usbip/libsrc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/usb/usbip/libsrc/Makefile.am b/tools/usb/usbip/libsrc/Makefile.am
new file mode 100644
index 000000000000..7c8f8a4d54e4
--- /dev/null
+++ b/tools/usb/usbip/libsrc/Makefile.am
@@ -0,0 +1,8 @@
+libusbip_la_CPPFLAGS = -DUSBIDS_FILE='"@USBIDS_DIR@/usb.ids"'
+libusbip_la_CFLAGS = @EXTRA_CFLAGS@
+libusbip_la_LDFLAGS = -version-info @LIBUSBIP_VERSION@
+
+lib_LTLIBRARIES := libusbip.la
+libusbip_la_SOURCES := names.c names.h usbip_host_driver.c usbip_host_driver.h \
+ usbip_common.c usbip_common.h vhci_driver.c vhci_driver.h \
+ sysfs_utils.c sysfs_utils.h