summaryrefslogtreecommitdiffstats
path: root/usr.sbin/nsd/configure.ac
diff options
context:
space:
mode:
authorsthen <sthen@openbsd.org>2018-02-20 09:20:47 +0000
committersthen <sthen@openbsd.org>2018-02-20 09:20:47 +0000
commita8d230d1cc8b21e63956d50d6af194408a38fa1b (patch)
treeffc76aa8d0bc0b9665e60f8f3b1f8a20589421d5 /usr.sbin/nsd/configure.ac
parenttweak previous, with some help from dlg; (diff)
downloadwireguard-openbsd-a8d230d1cc8b21e63956d50d6af194408a38fa1b.tar.xz
wireguard-openbsd-a8d230d1cc8b21e63956d50d6af194408a38fa1b.zip
merge configure.ac from NSD 4.1.19, previously we had an updated
generated configure file, but old configure.ac.
Diffstat (limited to 'usr.sbin/nsd/configure.ac')
-rw-r--r--usr.sbin/nsd/configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/usr.sbin/nsd/configure.ac b/usr.sbin/nsd/configure.ac
index 2ad31c51d32..7dd787eaed5 100644
--- a/usr.sbin/nsd/configure.ac
+++ b/usr.sbin/nsd/configure.ac
@@ -4,7 +4,7 @@ dnl
sinclude(acx_nlnetlabs.m4)
-AC_INIT(NSD,4.1.17,nsd-bugs@nlnetlabs.nl)
+AC_INIT(NSD,4.1.19,nsd-bugs@nlnetlabs.nl)
AC_CONFIG_HEADER([config.h])
CFLAGS="$CFLAGS"
@@ -918,6 +918,16 @@ case "$enable_radix_tree" in
;;
esac
+AC_ARG_ENABLE(packed, AC_HELP_STRING([--enable-packed], [Enable packed structure alignment, uses less memory, but unaligned reads.]))
+case "$enable_packed" in
+ yes)
+ AC_DEFINE_UNQUOTED([PACKED_STRUCTS], [], [Define this to use packed structure alignment.])
+ ACX_CHECK_COMPILER_FLAG(Wno-address-of-packed-member, [CFLAGS="$CFLAGS -Wno-address-of-packed-member"])
+ ;;
+ no|*)
+ ;;
+esac
+
AH_BOTTOM([
/* define before includes as it specifies what standard to use. */
#if (defined(HAVE_PSELECT) && !defined (HAVE_PSELECT_PROTO)) \
@@ -1096,6 +1106,12 @@ AH_BOTTOM([
#endif /* !__timespec_defined */
#endif /* !HAVE_STRUCT_TIMESPEC */
#endif /* !CONFIG_DEFINES */
+
+#ifdef PACKED_STRUCTS
+#define ATTR_PACKED __attribute__((packed))
+#else
+#define ATTR_PACKED
+#endif
])
# big fat warning