summaryrefslogtreecommitdiffstats
path: root/usr.sbin/nsd/configure.ac
diff options
context:
space:
mode:
authorjakob <jakob@openbsd.org>2010-01-17 19:32:40 +0000
committerjakob <jakob@openbsd.org>2010-01-17 19:32:40 +0000
commitfe5b952965b4c08b1fded64b3721c9a73d9e98a3 (patch)
tree7ba520c3aeb17928796c45843416da3d0c089c31 /usr.sbin/nsd/configure.ac
parentWhile resampling, if input samples are available but output (diff)
downloadwireguard-openbsd-fe5b952965b4c08b1fded64b3721c9a73d9e98a3.tar.xz
wireguard-openbsd-fe5b952965b4c08b1fded64b3721c9a73d9e98a3.zip
add --with-chroot option to set default chroot directory
Diffstat (limited to 'usr.sbin/nsd/configure.ac')
-rw-r--r--usr.sbin/nsd/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/usr.sbin/nsd/configure.ac b/usr.sbin/nsd/configure.ac
index ccabe1462c9..a16176758c1 100644
--- a/usr.sbin/nsd/configure.ac
+++ b/usr.sbin/nsd/configure.ac
@@ -123,6 +123,16 @@ AC_DEFINE_UNQUOTED(XFRDFILE, ["`eval echo $xfrdfile`"], [Pathname to the NSD xfr
AC_SUBST(xfrdfile)
#
+# Determine default chroot directory
+#
+chrootdir="/"
+AC_ARG_WITH([chroot],
+ AC_HELP_STRING([--with-chroot=dir], [NSD default chroot directory]),
+ [chrootdir=$withval])
+AC_SUBST(chrootdir)
+AC_DEFINE_UNQUOTED(CHROOTDIR, ["`eval echo $chrootdir`"], [NSD default chroot directory.])
+
+#
# Determine the user name to drop privileges to
#
user=nsd