summaryrefslogtreecommitdiffstats
path: root/sys/dev/softraid_raid6.c (follow)
Commit message (Expand)AuthorAgeFilesLines
* No need to rescan chunks in each discipline to find appropriatekrw2016-04-121-11/+1
* Enable creation of softraid volumes using disks with non-512 bytekrw2016-04-041-1/+11
* A few more daddr_t fixes. Rename 'phys_off' variables to 'offset'krw2015-07-211-11/+10
* Remove unneeded #include <disklabel.h>.krw2015-07-191-2/+1
* Stop passing daddr_t parameters for lengths. Use long since that's the typekrw2015-07-191-5/+5
* Stop adding and subtracting data offset. Just keep to chunk relativekrw2015-07-191-3/+2
* Nuke annoying whitespace nits to shrink some future diffs.krw2015-05-291-4/+4
* Remove some includes include-what-you-use claims don'tjsg2015-03-141-2/+1
* remove uneeded proc.h includesjsg2014-09-141-2/+1
* add a size argument to free. will be used soon, but for now default to 0.tedu2014-07-121-2/+2
* Move sr_dump from the RAID5 code into shared code. Rename it tojsing2014-01-221-2/+1
* Switch metadata saves from the system workq to the system taskq.jsing2014-01-221-2/+3
* Order the volume state transitions by state value.jsing2014-01-211-10/+10
* Move the block get/put routines into the common code, instead of havingjsing2014-01-181-9/+6
* Cast daddr_t variable to (long long) even for %llx!krw2013-11-211-2/+3
* Change a bunch of daddr_t variables that don't (obviously) containkrw2013-11-211-4/+6
* Fix RAID levels 0, 4, 5, and 6 with partitions larger than 2TB.reyk2013-11-051-3/+3
* Sprinkle (long long) casts where %lld is being used to print daddr_tkrw2013-11-011-3/+3
* final removal of daddr64_t. daddr_t has been 64 bit for a long enoughderaadt2013-06-111-7/+7
* Provide a function that handles the scheduling of work units. Thisjsing2013-05-211-19/+3
* Fix missing work unit state initialisations.jsing2013-05-211-1/+2
* Use a state to indicate that a work unit should only be constructed and notjsing2013-05-211-3/+3
* Convert RAID 6 to new work unit completion routines.jsing2013-04-271-59/+33
* Add a SR_WUF_DISCIPLINE flag that identifies work units that have resultedjsing2013-04-261-10/+8
* Convert RAID6 to new ccb handling.jsing2013-04-231-52/+18
* Do not pass SR_CCBF_FREEBUF unless we are passing an already allocatedjsing2013-04-231-29/+22
* Rename ccb_flag to ccb_flags.jsing2013-04-231-4/+4
* Use consistent error handling when validating the number of chunksjsing2013-03-311-3/+5
* Provide default resource allocation and free functions. Convert alljsing2013-03-311-38/+1
* Pull the initialisation of runtime values out into a separate initjsing2013-03-311-15/+20
* Provide wrappers for scsi_io_get() and scsi_io_put(), that also includejsing2013-03-301-6/+4
* Properly release ccbs when restarting a work unit.jsing2013-03-291-3/+2
* Convert RAID 4/5/6 to new ccb completion code.jsing2013-03-291-37/+17
* Decouple wakeups on work unit completion from the type of I/O beingjsing2013-03-291-8/+6
* sd_wu_pending is only decremented when scsi_done() or scsi_io_put() arejsing2013-03-291-7/+7
* Rewrite the work unit handling code in the RAID 1/4/5/6 interrupt handlers.jsing2013-03-271-73/+55
* Factor out the code that is used to recreate work units - one copy of thejsing2013-03-251-24/+2
* sr_alloc_resources() and sr_free_resources() can never be called withoutjsing2013-03-021-7/+1
* Consistently call sr_scsi_done instead of scsi_done.jsing2013-01-161-3/+3
* Add a new capability flag to identify disciplines where read failures arejsing2013-01-161-2/+3
* Set resid to zero if the scsi transfer completed without error.jsing2013-01-161-4/+2
* Factor out code used to release ccbs from a workunit.jsing2013-01-161-7/+2
* Always initialise the discipline name, not just when we are doing a create.jsing2013-01-151-4/+2
* Keep a function pointer to the per-discipline I/O interrupt handler in thejsing2013-01-151-1/+2
* Spell `calculation' correctly.miod2012-12-311-2/+2
* Provide a mechanism for the kernel to pass data through to the disciplinejsing2012-10-081-3/+3
* Initialise discipline function pointers with defaults and only overridejsing2011-12-251-14/+7
* Speedup XORP/XORQ operations in RAID6, do 32-bits at a timejordan2011-04-211-10/+15
* Remove unused code/arrayjordan2011-04-081-38/+2
* Fix raidp/raid6 to work with new iopool code, needed to swap wu'sjordan2011-04-081-30/+25