aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-07-13 23:15:01 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-07-13 23:15:01 +0200
commit7805fd9f596870046c3bc607f5e5199b738a02cb (patch)
treeb47a20e6e1736c5beafd473748d3b00f9bb7f847 /Cargo.toml
parentAdd peers and psks to device (diff)
downloadwireguard-rs-7805fd9f596870046c3bc607f5e5199b738a02cb.tar.xz
wireguard-rs-7805fd9f596870046c3bc607f5e5199b738a02cb.zip
Begin work on creating initiation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a83e3a1..8785ef3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,11 @@ authors = ["Mathias Hall-Andersen <mathias@hall-andersen.dk>"]
edition = "2018"
[dependencies]
-rand = "0.7.0"
+rand = "0.6.5"
+blake2 = "0.8.0"
+hmac = "0.7.1"
+chacha20-poly1305-aead = "0.1.2"
+generic-array = "0.13"
[dependencies.x25519-dalek]
version = "^0.5"