aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-07 22:51:58 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-07 22:51:58 +0200
commitb33381331f5c33037892bbc3c197376f3b8d945d (patch)
treee574fe1201a3107a12fd38e15ad8957613c28444 /Cargo.toml
parentAdded initiation flood protection (diff)
downloadwireguard-rs-b33381331f5c33037892bbc3c197376f3b8d945d.tar.xz
wireguard-rs-b33381331f5c33037892bbc3c197376f3b8d945d.zip
Concurrent rate limiter
The new rate limiter allows multiple simultaneous .allow calls. Also delegated GC to tokio.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2909dcc..c3af1c4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,6 +17,8 @@ byteorder = "1.3.1"
digest = "0.8.0"
sodiumoxide = "0.2.2"
lazy_static = "^1.3"
+tokio = "0.1.22"
+futures = "0.1.28"
[dependencies.x25519-dalek]
version = "^0.5"