aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Müller <mmueller@gnuradio.org>2019-08-10 01:01:56 +0200
committerMartin Braun <martin.braun@ettus.com>2020-01-04 18:48:20 -0800
commit678a7c2ad5db89e0634bfae2b0c9186f1ce63e89 (patch)
treea86eaf74a5ea951cc113f2260e539d6ab1a9e421 /CMakeLists.txt
parentmodtool: prevent tagged_stream under python (diff)
downloadgnuradio-678a7c2ad5db89e0634bfae2b0c9186f1ce63e89.tar.xz
gnuradio-678a7c2ad5db89e0634bfae2b0c9186f1ce63e89.zip
Disable Python 2k
- Update SWIG settings - Update CMake - Remove Python2 references Note: This does not touch a lot of Python files, and many Python files will still work with Python 2 after this commit. However, we won't allow that in our CMake, and the support will be gone too.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a842fb98..f7336d397 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,8 +61,7 @@ set(GR_BOOST_MIN_VERSION "1.53")
set(GR_SWIG_MIN_VERSION "3.0.8")
set(GR_CMAKE_MIN_VERSION "3.5.1")
set(GR_MAKO_MIN_VERSION "0.4.2")
-set(GR_PYTHON_MIN_VERSION "2.7.6")
-set(GR_PYTHON3_MIN_VERSION "3.6.5")
+set(GR_PYTHON_MIN_VERSION "3.6.5")
set(GCC_MIN_VERSION "4.8.4")
set(CLANG_MIN_VERSION "3.4.0")
set(APPLECLANG_MIN_VERSION "500")