aboutsummaryrefslogtreecommitdiffstats
path: root/src/gb/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2020-12-04 10:15:39 +0100
committerHarald Welte <laforge@osmocom.org>2020-12-04 10:17:21 +0100
commitd8e59b208c9f0a79ace235c30cf66a650e4fa92b (patch)
tree7b564d2fce01d0fa4a9238ffefb1734a264ad510 /src/gb/Makefile.am
parentns2: Add log filtering by NSE/NSEI, fix NSVC filter on receive (diff)
downloadlibosmocore-d8e59b208c9f0a79ace235c30cf66a650e4fa92b.tar.xz
libosmocore-d8e59b208c9f0a79ace235c30cf66a650e4fa92b.zip
libosmogb: Add missing LIBMNL_CFLAGS
In Change-Id I779556991bfc88b7751b2be17bb81c329cfb9e01 we introduced the use of libmnl via osmo_mnl to libosmogb. Howver, we didn't add LIBMNL_CFLAGS in Makefile.am, which now (rightfully) fails on some distributions like the SuSE family of distributions. Let's fix this. Change-Id: Ib8740e8fd677026efb9dad5d5fe6b95147fb3c23
Diffstat (limited to 'src/gb/Makefile.am')
-rw-r--r--src/gb/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/gb/Makefile.am b/src/gb/Makefile.am
index 41b6c6db..b1407275 100644
--- a/src/gb/Makefile.am
+++ b/src/gb/Makefile.am
@@ -4,7 +4,10 @@
LIBVERSION=11:0:0
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS = -Wall ${GCC_FVISIBILITY_HIDDEN} -fno-strict-aliasing $(TALLOC_CFLAGS)
+AM_CFLAGS = -Wall ${GCC_FVISIBILITY_HIDDEN} -fno-strict-aliasing \
+ $(TALLOC_CFLAGS) \
+ $(LIBMNL_CFLAGS) \
+ $(NULL)
# FIXME: this should eventually go into a milenage/Makefile.am
noinst_HEADERS = common_vty.h gb_internal.h gprs_bssgp_internal.h gprs_ns2_internal.h